jUpgrade - Migration vers Joomla! 2.5+

  • Téléchargement :
    Libre
  • Type de licence :
  • No de version :
    Voir site auteur
  • Mis à jour le :
    Vendredi, 06 Février 2015
  • Appréciation :
    (61 votes)
  • Ajouter aux favoris :
    Ajouter aux favoris (3 utilisateurs)
jUpgrade est un composant permettant de créer un site Joomla 2.5 à partir des données du site Joomla 1.5 dans lequel il est installé. Les données de certaines extensions tierces sont prises en charge mais elles doivent être installées dans le nouveau site.
Dernière mise à jour
jUpgrade est proposé pour migrer vers la dernière version Joomla 2.5.28, vous devez ensuite installer la version Joomla 3.x upgrade
Pour migrer directement vers Joomla 3.x vous devez utiliser l'extension "redMIGRATOR"
Présentation
Note : le composant ne met pas à jour votre version de Joomla 1.5, mais effectue une installation d'un nouveau site en version 1.7 ou 2.5 à choix, en récupérant les données du site de base. Les données de Joomla ainsi que celles de certaines extensions sont insérées dans les tables (base de données) du nouveau site ; les extensions doivent ensuite être installées. 

Étapes d'utilisation

  • Installer le composant sous Joomla 1.5
  • Adaptez les paramètres selon vos souhaits
  • Démarrez la migration et patientez, cela peut prendre du temps selon :
    • votre débit de connexion pour le téléchargement de Joomla ;
    • votre serveur pour la décompression ;
    • la quantité de données à migrer.
  • Lors du processus, le nouveau site est automatiquement déployé dans un sous-répertoire du site original.
  • Les données sont ajoutés dans de nouvelles tables de la même base de données ayant pour préfixe : jnew_
  • Après la migration, l'ancien site doit être supprimé et remplacé par le nouveau site, le fichier 'configuration.php' est configuré ainsi. Si dans un premier temps vous ne souhaitez pas effacer l'ancien site, vous pouvez le glisser dans un nouveau dossier.
  • Dans le nouveau site, vous devez supprimé le dossier d'installation renommé 'installation-old' et le dossier original des images renommé 'images.orig'.
  • Lorsque vous vous connectez à l'administration pour la première fois, il vous sera demandé de mettre à jour le pack de langue FR. Il est noté que c'est la version 2.5.4v2 qui sera installée mais c'est bien la 2.5.6v1.
Si vous avez déjà fait une migration et souhaitez en faire une nouvelle avec des réglages différents, recharger la page avant de lancer le processus. Il peut arriver que la désinstallation et la réinstallation du composant soit nécessaire.

Paramètres de migration

Paramètres jUpgrade

Étapes de migration

jupgrade etape

 

Après la migration, le site original doit être supprimé et remplacé par le nouveau site (les chemins dans le fichier configuration.php sont ainsi écrits)

deplacer le site

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Informations
Éléments migrés de Joomla
  • Bannières - 100%
  • Categories - 100%
  • Contacts - 100%
  • Content - 100%
  • Menus - 100%
  • Modules - 100%
  • Fil d'Informations - 100%
  • Utilisateurs - 100%
  • Url - 100%
Éléments migrés d'extensions tierces
  • AceSEF
  • Acymailing
  • Admin Tools
  • Adminpraise
  • AdsManager
  • aiContactSEF
  • Akeeba Backup
  • Akeeba Release System (ARS)
  • Allevents
  • AmbraSuscriptions
    (données récupérables par Akeeba Suscriptions)
  • AvReloaded
  • CommunityBuilder
  • Contact Enhanced
  • CSV Improved
  • DOCman
  • FLEXIcontent
  • FlippingBook
  • GCalendar
  • Highslide JS
  • JCE + plugins installés
    Note : Vous devez réattribuer les profils aux groupes souhaités (différents dans Joomla 2.5)
  • JComments
  • JEvents
  • Jumi
  • Kunena avec installation complète
    Nécessite juste l'installation du fichier langue FR
  • K2
  • JomSocial
  • JoomComment
  • PHP
  • redFORM
  • redMEMBER
  • redSHOP
  • redTEXTLIBRARY
  • RokQuickCart
  • SobiPro
  • Virtuemart 2 avec installation complète
    Nécessite juste l'installation du fichier langue FR et de lancer la découverte des modules et plugins
    (Merci à Patrick Kohl)
  • Xmap

Conditions système

  • PHP 5.2.4+
  • MySQL 5.0.4+
  • Activation du plug-in Mootools 2 (présent depuis Joomla 1.5.19)
  • Navigateur supportant le JavaScript et Mootools
Une réalisation de Matias Aguirre : http://matware.com.ar/
Adaptation FR et ajout de prise en charge de nouvelles extensions par Mihàly Marti alias Sarki
  • Créé le :
    Mardi, 28 Février 2012
  • Créé par :
    Mihàly Marti
  • Clics sur l'article :
    179699 views

Qui est en ligne ?

Nous avons 274 invités en ligne